Search found 876 matches

by 75evo
Mon Dec 31, 2018 8:06 pm
Forum: Engine
Topic: Engine coolant mostly gone
Replies: 12
Views: 1496

Re: Engine coolant mostly gone

I’m still monitoring it, a few days now and no loss of coolant. I think if this holds up for the next few days, then I can say the leak problem has been solved.
by 75evo
Sun Dec 30, 2018 9:42 pm
Forum: Race Cars and Track preparation
Topic: Project 2 : front mount SA GTV 3.0 - Sei diff
Replies: 409
Views: 83874

Re: Project 2 : front mount SA GTV 3.0 - Sei diff

I was thinking of getting my dash covered in an alcantara/suede style material. So instead of the wrinkle stuff, need fury stuff. MD, any suggestions? :lol:
by 75evo
Sat Dec 29, 2018 3:54 pm
Forum: Engine
Topic: Engine coolant mostly gone
Replies: 12
Views: 1496

Re: Engine coolant mostly gone

I've put the K-Seal in. Before putting it in, I mixed it thoroughly with warm water. Ran the car till about 85C and shut it off. Radiator is not in the car and I will drain the fluid and remove all the K-Seal stuff that's in the engine. Once it's all gone and only the part needed to seal the small l...
by 75evo
Fri Dec 28, 2018 3:24 pm
Forum: Other
Topic: WANTED Gtv6 in the Bay Area for Wedding Day Photo
Replies: 2
Views: 552

Re: WANTED Gtv6 in the Bay Area for Wedding Day Photo

Congrats! I don't know anyone with a red GTV6, but I hope you will find someone with one soo.

BTW, Vittorio, Mike and me are still quite young :D

Old guard = MD

Very old guard = Jim K

:mrgreen:
by 75evo
Thu Dec 27, 2018 10:57 am
Forum: Race Cars and Track preparation
Topic: Project 2 : front mount SA GTV 3.0 - Sei diff
Replies: 409
Views: 83874

Re: Project 2 : front mount SA GTV 3.0 - Sei diff

Fantastic project. Was that designed in Autocad?
by 75evo
Tue Dec 25, 2018 11:32 pm
Forum: Site Administration & announcements
Topic: MERRY CHRISTMAS TO EVERYONE
Replies: 4
Views: 690

Re: MERRY CHRISTMAS TO EVERYONE

Nothing yet Kev, just came back from LA with the family. Was busy looking into the big V8 Landcruiser, installing a new car stereo in it last week, final checks for our trip to LA last weekend. We are back home now. Back to car work for the next one week, Will update my thread. Hope everyone had a n...
by 75evo
Mon Nov 19, 2018 9:33 am
Forum: Engine
Topic: Engine coolant mostly gone
Replies: 12
Views: 1496

Re: Engine coolant mostly gone

Pretty sure it's a liner seal problem as I had no overheating problems 2 weeks ago at the track. I think I can summarize it as follows: Over-pressurized coolant bottle when engine is warm: leaking head gasket at the fire ring. Combustion gas getting into the coolant. Coolant in oil but not oil in co...
by 75evo
Tue Nov 13, 2018 7:06 am
Forum: Engine
Topic: Engine coolant mostly gone
Replies: 12
Views: 1496

Re: Engine coolant mostly gone

Didn't have any steam in the pipes, and no over pressurizing of the coolant bottle. My guess is a leaky liner seal. I'm gonna remove my radiator and make the coolant piping direct from one end of the thermostat to the other and put some alumaseal in there. I had good luck using that in my 12V. But I...
by 75evo
Mon Nov 12, 2018 10:03 pm
Forum: Engine
Topic: Engine coolant mostly gone
Replies: 12
Views: 1496

Engine coolant mostly gone

Damn it! I let the 3.2 24V sit around for 2 weeks and the coolant disappeared! But the good news is, stone cold engine, compression with JK 10mm cams are 220-230 psi. I'm hoping it's not the damn liner seals. It ran pretty well at the track with no overheating, how the heck can the coolant just vani...
by 75evo
Mon Oct 29, 2018 7:31 am
Forum: Engine
Topic: Engine mounts
Replies: 12
Views: 1100

Re: Engine mounts

But one stud didn't quite get in due to a beer belly......
by 75evo
Sun Oct 28, 2018 9:50 am
Forum: Engine
Topic: Engine mounts
Replies: 12
Views: 1100

Re: Engine mounts

Well the mount is old, and it has"bloated" a bit, porbably compressed which means it expended on the sides due to age. Similar to a beer belly ..... I'm not touching that mounts anymore, more trouble than it's worth. Especially after aligning the engine and driveshaft. I don't remember slotting the ...
by 75evo
Sat Oct 27, 2018 2:06 pm
Forum: Engine
Topic: Engine mounts
Replies: 12
Views: 1100

Re: Engine mounts

I couldn’t get the nut fattened on the driver’s side lower engine mount stud because the rubber block was too close to it. So the engine only has 3 fastened points at the front instead of 4.
by 75evo
Thu Oct 25, 2018 12:44 pm
Forum: Engine
Topic: Engine mounts
Replies: 12
Views: 1100

Re: Engine mounts

You have a RHD car, so I'm assuming with the booster on the driver's side, you've removed the linkage rod for the brakes? Where are you located mate?
by 75evo
Wed Oct 24, 2018 8:59 pm
Forum: Engine
Topic: Engine mounts
Replies: 12
Views: 1100

Re: Engine mounts

24v

Lovely car mate, and thanks for the idea but my car has a 164 engine so not quite the same innit? But you’ve given me an idea. Probably will use your idea with some mods. Cheers.
by 75evo
Wed Oct 24, 2018 10:17 am
Forum: Engine
Topic: Engine mounts
Replies: 12
Views: 1100

Engine mounts

Guys, I slotted all my engine mounts and on the driver's side (LHD) of the car I had to also weld a small piece of metal to the metal part of the engine rubber mount. For that mount, the rubber is too close to the bottom stud and I can't screw the M8 nut . I'm thinking of a custom engine mount using...