Can't get the Tacho working with EDIS

Related to the Bowling & Grippo Fuel Injection system.
Post Reply
Posts: 10
Joined: Mon Mar 28, 2005 7:00 am
Location: Melbourne Australia

Can't get the Tacho working with EDIS

Post by sammbo » Mon Jul 25, 2011 4:21 am


I know this forum is for GTV6ers, and my case refers to a GTV4, but I'm hoping similarities with the Alfetta tachometers are consistent enough for someone to be able to help me.

I tried posting elsewhere but nobody has responded. This is my final try, so I hope someone out there can help.

I have almost completed my MSII build and for ignition I want to control an EDIS 4 module with it.

I have recently installed the EDIS but without the MSII to control it, I just have it running in default mode (i.e. 10deg advance).

The problem is that I can't get the Alfetta tacho to work from the EDIS 4 controller.

I tried the CTO and IDM signals but no bloody good.

I read a post in a BWM forum that mentioned using a .22uf cap to filter the signal, I tried that but still NBG.

I tried the circuit mentioned in the Megasquirt manual - with the 2 diodes and the zener diode but still NBG.

Has anyone got this working on their GTV6?

If so how ?

thanks in advance
I'd rather push my Alfa than drive Jap crap.
Come to think of it, I often do ! :roll:
Post Reply